No hay motivo para no actualizar tu R a la última versión

Ayer se publicó la versión 3.1.0 de R. No es gran noticia: aparecen nuevas versiones cada no muchos meses.

No hay motivo para no actualizar. Pero sí para hacerlo: las nuevas versiones corrigen errores en las anteriores y, además, encontrarás poco soporte en los foros para ese R 2.1.5 viejuno que aún mantienes por pereza.

Para quienes usen R en plataformas donde el software no se actualiza automágicamente, existe el paquete installr que permite actualizar la versión de R con menos esfuerzo que antaño haciendo

install.packages("installr")
library(installr) 
updateR()

2 comentarios sobre “No hay motivo para no actualizar tu R a la última versión

  1. David 14 abril, 2014 13:23

    Vaya, tu post me había parecido la excusa perfecta para actualizar ese R viejuno que mantenía por pereza,…
    pero…

    install.packages(«installr»)
    Warning in install.packages :
    package ‘installr’ is not available (for R version 2.15.3)

    Parece que sí que es viejuno.

  2. Carlos J. Gil Bellosta 14 abril, 2014 13:26

    ¡Vergüenza debería darte!

    De todos modos, el paquete en cuestión no hace magia. Basta con instalarte la versión nueva y reinstalar los paqutes que tienes instalados actualmente. Puedes sacar una lista usando installed.packages() en tu versión antigua y copiándola en la nueva. No cuesta nada.

Los comentarios están desabilitados.